summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/xwindowlistener/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-10-10 12:47:42 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-10-10 12:47:42 +0000
commitaa94247770732a40e46ab3d539dd9987062abef4 (patch)
tree1509ca08f33718ccb6cb63f1c1ad1f5b4752801b /gst-libs/gst/xwindowlistener/Makefile.am
parent39b91cdb495b9f9b326e79a10f64753a097c203c (diff)
downloadgst-plugins-bad-aa94247770732a40e46ab3d539dd9987062abef4.tar.gz
gst-plugins-bad-aa94247770732a40e46ab3d539dd9987062abef4.tar.bz2
gst-plugins-bad-aa94247770732a40e46ab3d539dd9987062abef4.zip
Some interface implementations for video4linux/video4linux2 plugins: a Tuner interface, with which one can select inp...
Original commit message from CVS: Some interface implementations for video4linux/video4linux2 plugins: * a Tuner interface, with which one can select inputs and stations. Audio work is underway here, but unfinished. * A Xoverlay interface with which one can do simple overlay. Similar to the API of the v4l/Xv XFree86 extension. Widget implementation for GTK-2.0 coming up in the sandbox. * Colorbalance - for adapting colors (brightness, contrast, etc.) - pretty basic and maybe somewhat overdesigned. But it'll do for now. Apart from these interfaces, there's also a loadable library 'xwindowlistener' that listenes to X for the movement of a window and the overlap of other windows. This is partly copied from xawtv (and thus partly GPL :(), but it's needed for the xoverlay interface implementation in the v4l/v4l2 elements. Lastly, some small changes to remove redundant properties from the v4l/v4l2 elements since these can be done much simpler. Comments appreciated!
Diffstat (limited to 'gst-libs/gst/xwindowlistener/Makefile.am')
-rw-r--r--gst-libs/gst/xwindowlistener/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/gst-libs/gst/xwindowlistener/Makefile.am b/gst-libs/gst/xwindowlistener/Makefile.am
new file mode 100644
index 00000000..a3a589ba
--- /dev/null
+++ b/gst-libs/gst/xwindowlistener/Makefile.am
@@ -0,0 +1,11 @@
+librarydir = $(libdir)/gstreamer-@GST_MAJORMINOR@
+
+library_LTLIBRARIES = libgstxwindowlistener.la
+
+libgstxwindowlistener_la_SOURCES = xwindowlistener.c
+
+libraryincludedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/xwindowlistener
+libraryinclude_HEADERS = xwindowlistener.h
+
+libgstxwindowlistener_la_CFLAGS = $(GST_CFLAGS) $(X_CFLAGS)
+libgstxwindowlistener_la_LIBADD = $(GST_LIBS) $(GST_PLUGIN_LIBS) $(X_LIBS)