summaryrefslogtreecommitdiffstats
path: root/gst/camerabin/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@fluendo.com>2009-02-09 15:48:20 +0100
committerJulien Moutte <julien@fluendo.com>2009-02-09 15:48:20 +0100
commitfe54254bd9d019fe768f384c20ecc21b57fd4a48 (patch)
treee4693b8602ef33638d795866ef9e10411a28ddc8 /gst/camerabin/Makefile.am
parentf4ebf3e2aa52862c4025d5aaee509b1af40f355a (diff)
downloadgst-plugins-bad-fe54254bd9d019fe768f384c20ecc21b57fd4a48.tar.gz
gst-plugins-bad-fe54254bd9d019fe768f384c20ecc21b57fd4a48.tar.bz2
gst-plugins-bad-fe54254bd9d019fe768f384c20ecc21b57fd4a48.zip
Fix build for camerabin.
Diffstat (limited to 'gst/camerabin/Makefile.am')
-rw-r--r--gst/camerabin/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/gst/camerabin/Makefile.am b/gst/camerabin/Makefile.am
index 8a5cc382..583b2c55 100644
--- a/gst/camerabin/Makefile.am
+++ b/gst/camerabin/Makefile.am
@@ -27,11 +27,13 @@ nodist_libgstcamerabin_la_SOURCES = $(built_sources)
# libcamerabin_la_HEADERS = gstcamerabin.h
-libgstcamerabin_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
+libgstcamerabin_la_CFLAGS = \
+ $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
-libgstcamerabin_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) \
- -lgstinterfaces-$(GST_MAJORMINOR) \
- $(top_builddir)/gst-libs/gst/interfaces/libgstphotography-$(GST_MAJORMINOR).la
+libgstcamerabin_la_LIBADD = \
+ $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstinterfaces-$(GST_MAJORMINOR) \
+ $(top_builddir)/gst-libs/gst/interfaces/libgstphotography-$(GST_MAJORMINOR).la
libgstcamerabin_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstcamerabin__la_LIBTOOLFLAGS = --tag=disable-static