summaryrefslogtreecommitdiffstats
path: root/gst/deinterlace/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-10-11 20:33:48 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-10-11 20:33:48 +0000
commit16c7b30edd8963d002b38c27648beb40176b9db1 (patch)
tree67dcb933e143abea2c19abfd88212df5b427f92a /gst/deinterlace/Makefile.am
parent746bb0e2fad60dedd9a486606da289edff3d797e (diff)
downloadgst-plugins-bad-16c7b30edd8963d002b38c27648beb40176b9db1.tar.gz
gst-plugins-bad-16c7b30edd8963d002b38c27648beb40176b9db1.tar.bz2
gst-plugins-bad-16c7b30edd8963d002b38c27648beb40176b9db1.zip
Port simple deinterlacer from 0.8. Use at your own risk, don't blame me for anything it does or does not do to your p...
Original commit message from CVS: * configure.ac: * gst/deinterlace/Makefile.am: * gst/deinterlace/gstdeinterlace.c: (gst_deinterlace_base_init), (gst_deinterlace_class_init), (gst_deinterlace_init), (gst_deinterlace_stop), (gst_deinterlace_transform_caps), (gst_deinterlace_set_caps), (gst_deinterlace_transform_ip), (gst_deinterlace_set_property), (gst_deinterlace_get_property): * gst/deinterlace/gstdeinterlace.h: Port simple deinterlacer from 0.8. Use at your own risk, don't blame me for anything it does or does not do to your precious pictures.
Diffstat (limited to 'gst/deinterlace/Makefile.am')
-rw-r--r--gst/deinterlace/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/gst/deinterlace/Makefile.am b/gst/deinterlace/Makefile.am
index 5af2998b..22a691b5 100644
--- a/gst/deinterlace/Makefile.am
+++ b/gst/deinterlace/Makefile.am
@@ -1,9 +1,9 @@
-
plugin_LTLIBRARIES = libgstdeinterlace.la
+# NOTE: we don't need $(GST_PLUGINS_BASE_LIBS) at the moment
libgstdeinterlace_la_SOURCES = gstdeinterlace.c
-libgstdeinterlace_la_CFLAGS = $(GST_CFLAGS)
-libgstdeinterlace_la_LIBADD =
+libgstdeinterlace_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstdeinterlace_la_LIBADD = $(GST_BASE_LIBS)
libgstdeinterlace_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstdeinterlace.h