summaryrefslogtreecommitdiffstats
path: root/gst/dvdspu/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@noraisin.net>2009-05-20 08:55:40 +0100
committerJan Schmidt <thaytan@noraisin.net>2009-05-26 15:31:54 +0100
commit4e847cb4acd356112f56a101132d8438abe9fa03 (patch)
tree20c10a71131bcd6463cdf807ba659715b999ee6a /gst/dvdspu/Makefile.am
parent78cd406a76c71b2ebe5457e838471cd209afd6d0 (diff)
downloadgst-plugins-bad-4e847cb4acd356112f56a101132d8438abe9fa03.tar.gz
gst-plugins-bad-4e847cb4acd356112f56a101132d8438abe9fa03.tar.bz2
gst-plugins-bad-4e847cb4acd356112f56a101132d8438abe9fa03.zip
dvdspu: Add simple PGS handler that dumps the packet info
Add setcaps logic on the subpicture sink pad for configuring which subpicture format is arriving. Add the first piece of PGS subpicture handling by dumping the stream contents out to the terminal as the packets arrive. Add some more debug. Don't calculate the running time for our subpicture packets twice, once is enough.
Diffstat (limited to 'gst/dvdspu/Makefile.am')
-rw-r--r--gst/dvdspu/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/dvdspu/Makefile.am b/gst/dvdspu/Makefile.am
index 4d75f76c..2edd6e5e 100644
--- a/gst/dvdspu/Makefile.am
+++ b/gst/dvdspu/Makefile.am
@@ -1,13 +1,13 @@
plugin_LTLIBRARIES = libgstdvdspu.la
-libgstdvdspu_la_SOURCES = gstdvdspu.c gstdvdspu-render.c
+libgstdvdspu_la_SOURCES = gstdvdspu.c gstdvdspu-render.c gstspu-pgs.c
libgstdvdspu_la_CFLAGS = $(GST_CFLAGS)
libgstdvdspu_la_LIBADD = $(GST_LIBS)
libgstdvdspu_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstdvdspu_la_LIBTOOLFLAGS = --tag=disable-static
-noinst_HEADERS = gstdvdspu.h
+noinst_HEADERS = gstdvdspu.h gstspu-pgs.h
EXTRA_DIST = Notes.txt