summaryrefslogtreecommitdiffstats
path: root/gst/equalizer/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2007-02-03 23:35:26 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-02-03 23:35:26 +0000
commitadd17e34f0b5d163bd09e02b95c19ec6b9473945 (patch)
tree50168cc7aca50d988fa6275705a6c4ab4f127e6e /gst/equalizer/Makefile.am
parentd5bd74dcf6384ef42b66658d8826b6d5d6eaa76d (diff)
downloadgst-plugins-bad-add17e34f0b5d163bd09e02b95c19ec6b9473945.tar.gz
gst-plugins-bad-add17e34f0b5d163bd09e02b95c19ec6b9473945.tar.bz2
gst-plugins-bad-add17e34f0b5d163bd09e02b95c19ec6b9473945.zip
Fix up to use the newly ported (actually working) GstAudioFilter.
Original commit message from CVS: * configure.ac: * gst/equalizer/Makefile.am: * gst/equalizer/gstiirequalizer.c: (gst_iir_equalizer_base_init), (gst_iir_equalizer_class_init), (gst_iir_equalizer_init), (setup_filter), (gst_iir_equalizer_compute_frequencies), (gst_iir_equalizer_set_property), (gst_iir_equalizer_get_property), (gst_iir_equalizer_transform_ip), (gst_iir_equalizer_setup), (plugin_init): * gst/equalizer/gstiirequalizer.h: Fix up to use the newly ported (actually working) GstAudioFilter. Bump core/base requirements to CVS for this. * tests/icles/.cvsignore: * tests/icles/Makefile.am: * tests/icles/equalizer-test.c: (check_bus), (equalizer_set_band_value), (equalizer_set_all_band_values), (equalizer_set_band_value_and_wait), (equalizer_set_all_band_values_and_wait), (do_slider_fiddling), (main): Add brain-dead interactive test for equalizer.
Diffstat (limited to 'gst/equalizer/Makefile.am')
-rw-r--r--gst/equalizer/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gst/equalizer/Makefile.am b/gst/equalizer/Makefile.am
index ed26e295..1ef12c94 100644
--- a/gst/equalizer/Makefile.am
+++ b/gst/equalizer/Makefile.am
@@ -1,6 +1,8 @@
plugin_LTLIBRARIES = libgstequalizer.la
-libgstequalizer_la_SOURCES = gstiirequalizer.c
+libgstequalizer_la_SOURCES = gstiirequalizer.c gstiirequalizer.h
libgstequalizer_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
libgstequalizer_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR)
libgstequalizer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstiirequalizer.h