summaryrefslogtreecommitdiffstats
path: root/gst/equalizer/Makefile.am
diff options
context:
space:
mode:
authorJames Doc Livingston <doclivingston@gmail.com>2007-02-02 17:39:21 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-02-02 17:39:21 +0000
commitc2306bc88fd5fd471e4778c9876ea4c4a3759b53 (patch)
treee11aef50cc5cbbf7352edcfe27f4d168ad294ffe /gst/equalizer/Makefile.am
parent91e91243a9f7be56df0be83f39a004f04b733294 (diff)
downloadgst-plugins-bad-c2306bc88fd5fd471e4778c9876ea4c4a3759b53.tar.gz
gst-plugins-bad-c2306bc88fd5fd471e4778c9876ea4c4a3759b53.tar.bz2
gst-plugins-bad-c2306bc88fd5fd471e4778c9876ea4c4a3759b53.zip
Port equalizer plugin to 0.10 (#403572).
Original commit message from CVS: Patch by: James "Doc" Livingston <doclivingston at gmail com> * configure.ac: * gst/equalizer/Makefile.am: * gst/equalizer/gstiirequalizer.c: (gst_iir_equalizer_get_type), (gst_iir_equalizer_base_init), (gst_iir_equalizer_class_init), (gst_iir_equalizer_compute_frequencies), (gst_iir_equalizer_set_property), (gst_iir_equalizer_filter_inplace), (gst_iir_equalizer_setup), (plugin_init): Port equalizer plugin to 0.10 (#403572).
Diffstat (limited to 'gst/equalizer/Makefile.am')
-rw-r--r--gst/equalizer/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/gst/equalizer/Makefile.am b/gst/equalizer/Makefile.am
index d85bc5a4..ed26e295 100644
--- a/gst/equalizer/Makefile.am
+++ b/gst/equalizer/Makefile.am
@@ -1,6 +1,6 @@
plugin_LTLIBRARIES = libgstequalizer.la
libgstequalizer_la_SOURCES = gstiirequalizer.c
-libgstequalizer_la_CFLAGS = $(GST_CFLAGS)
-libgstequalizer_la_LIBADD =
-libgstequalizer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -lm
+libgstequalizer_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstequalizer_la_LIBADD = $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR)
+libgstequalizer_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)