summaryrefslogtreecommitdiffstats
path: root/gst/flv/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2007-07-19 15:05:30 +0000
committerJulien Moutte <julien@moutte.net>2007-07-19 15:05:30 +0000
commitfaea34bf985e95c4356e96a88737273baa6ad94b (patch)
tree694f0e6f98c0868550bf0c9aa08c48ef59d46326 /gst/flv/Makefile.am
parent6cbacb8a1497c21208edd0507986c2e263d17bfc (diff)
downloadgst-plugins-bad-faea34bf985e95c4356e96a88737273baa6ad94b.tar.gz
gst-plugins-bad-faea34bf985e95c4356e96a88737273baa6ad94b.tar.bz2
gst-plugins-bad-faea34bf985e95c4356e96a88737273baa6ad94b.zip
Adds a first draft of an FLV demuxer.
Original commit message from CVS: 2007-07-19 Julien MOUTTE <julien@moutte.net> * configure.ac: * gst/flv/Makefile.am: * gst/flv/gstflvdemux.c: (gst_flv_demux_flush), (gst_flv_demux_cleanup), (gst_flv_demux_chain), (gst_flv_demux_pull_tag), (gst_flv_demux_pull_header), (gst_flv_demux_seek_to_prev_keyframe), (gst_flv_demux_loop), (gst_flv_demux_sink_activate), (gst_flv_demux_sink_activate_push), (gst_flv_demux_sink_activate_pull), (gst_flv_demux_sink_event), (gst_flv_demux_change_state), (gst_flv_demux_dispose), (gst_flv_demux_base_init), (gst_flv_demux_class_init), (gst_flv_demux_init), (plugin_init): * gst/flv/gstflvdemux.h: * gst/flv/gstflvparse.c: (FLV_GET_BEUI24), (FLV_GET_STRING), (gst_flv_demux_query_types), (gst_flv_demux_query), (gst_flv_parse_metadata_item), (gst_flv_parse_tag_script), (gst_flv_parse_tag_audio), (gst_flv_parse_tag_video), (gst_flv_parse_tag_type), (gst_flv_parse_header): * gst/flv/gstflvparse.h: Adds a first draft of an FLV demuxer. It does not do seeking yet, it supports pull and push mode so YES you can use it to play youtube videos directly from an HTTP uri. Not so much testing done yet but it parses metadata, reply to duration queries, etc...
Diffstat (limited to 'gst/flv/Makefile.am')
-rw-r--r--gst/flv/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gst/flv/Makefile.am b/gst/flv/Makefile.am
new file mode 100644
index 00000000..7850e7ee
--- /dev/null
+++ b/gst/flv/Makefile.am
@@ -0,0 +1,9 @@
+
+plugin_LTLIBRARIES = libgstflvdemux.la
+
+libgstflvdemux_la_CFLAGS = ${GST_CFLAGS}
+libgstflvdemux_la_LIBADD = $(GST_BASE_LIBS)
+libgstflvdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
+libgstflvdemux_la_SOURCES = gstflvdemux.c gstflvparse.c
+
+noinst_HEADERS = gstflvdemux.h gstflvparse.h