summaryrefslogtreecommitdiffstats
path: root/gst/id3tag/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@songbirdnest.com>2009-05-21 13:15:46 -0700
committerMichael Smith <msmith@songbirdnest.com>2009-05-21 13:15:46 -0700
commitfe38f53572ff91b63a3dc5a5a5ed78e13040d16c (patch)
treeda2e7e402b107f5690a78df21b63e377ac692291 /gst/id3tag/Makefile.am
parentb9ac26713b9c4097373082a47c960d314a19119a (diff)
downloadgst-plugins-bad-fe38f53572ff91b63a3dc5a5a5ed78e13040d16c.tar.gz
gst-plugins-bad-fe38f53572ff91b63a3dc5a5a5ed78e13040d16c.tar.bz2
gst-plugins-bad-fe38f53572ff91b63a3dc5a5a5ed78e13040d16c.zip
id3tag: Add new id3 tagging plugin, supports v1, v2.3, and v2.4.
By default, does v1 and v2.3, but there are properties to select. Will hopefully replace id3mux, id3v2mux, in the not-too-distant future.
Diffstat (limited to 'gst/id3tag/Makefile.am')
-rw-r--r--gst/id3tag/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/gst/id3tag/Makefile.am b/gst/id3tag/Makefile.am
new file mode 100644
index 00000000..9595be0f
--- /dev/null
+++ b/gst/id3tag/Makefile.am
@@ -0,0 +1,19 @@
+plugin_LTLIBRARIES = libgstid3tag.la
+
+libgstid3tag_la_SOURCES = \
+ gsttagmux.c \
+ id3tag.c \
+ gstid3tag.c
+
+libgstid3tag_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_CFLAGS)
+
+libgstid3tag_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgsttag-$(GST_MAJORMINOR) \
+ $(GST_LIBS)
+
+libgstid3tag_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstid3tag_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstid3tag.h id3tag.h gsttagmux.h