summaryrefslogtreecommitdiffstats
path: root/gst/legacyresample/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2009-01-23 12:46:28 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-01-23 12:47:19 +0100
commite4e3b44e048ddc1d7499c6108175a5f89c6273d9 (patch)
treef88b685f1b6baf849649494ec557d2ef0ef13a88 /gst/legacyresample/Makefile.am
parent6fec8619b597f5cc9c58d268ddd9f64ea0a94277 (diff)
downloadgst-plugins-bad-e4e3b44e048ddc1d7499c6108175a5f89c6273d9.tar.gz
gst-plugins-bad-e4e3b44e048ddc1d7499c6108175a5f89c6273d9.tar.bz2
gst-plugins-bad-e4e3b44e048ddc1d7499c6108175a5f89c6273d9.zip
Rename audioresample files and types to legacyresample
Finish the move/rename of audioresample to legacyresample to prevent any confusion.
Diffstat (limited to 'gst/legacyresample/Makefile.am')
-rw-r--r--gst/legacyresample/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/gst/legacyresample/Makefile.am b/gst/legacyresample/Makefile.am
new file mode 100644
index 00000000..41abdc67
--- /dev/null
+++ b/gst/legacyresample/Makefile.am
@@ -0,0 +1,23 @@
+plugin_LTLIBRARIES = libgstlegacyresample.la
+
+resample_SOURCES = \
+ functable.c \
+ resample.c \
+ resample_functable.c \
+ resample_ref.c \
+ resample_chunk.c \
+ resample.h \
+ buffer.c
+
+noinst_HEADERS = \
+ gstlegacyresample.h \
+ functable.h \
+ debug.h \
+ buffer.h
+
+libgstlegacyresample_la_SOURCES = gstlegacyresample.c $(resample_SOURCES)
+libgstlegacyresample_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(LIBOIL_CFLAGS)
+libgstlegacyresample_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(LIBOIL_LIBS)
+libgstlegacyresample_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstlegacyresample_la_LIBTOOLFLAGS = --tag=disable-static
+