summaryrefslogtreecommitdiffstats
path: root/gst/mpegvideoparse/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2007-03-15 20:48:08 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2007-03-15 20:48:08 +0000
commit1f7755917a0db1c6e4aa9ef9a194499d7e84e6fe (patch)
tree3a47a261002558a61b362db676b5af4ec5a1d242 /gst/mpegvideoparse/Makefile.am
parent03ab530205fa1194a2deb1c38886f5b5978399a2 (diff)
downloadgst-plugins-bad-1f7755917a0db1c6e4aa9ef9a194499d7e84e6fe.tar.gz
gst-plugins-bad-1f7755917a0db1c6e4aa9ef9a194499d7e84e6fe.tar.bz2
gst-plugins-bad-1f7755917a0db1c6e4aa9ef9a194499d7e84e6fe.zip
Port mpeg1videoparse to 0.10 and give it rank SECONDARY-1, so that it's below existing decoders.
Original commit message from CVS: * configure.ac: * gst/mpeg1videoparse/Makefile.am: * gst/mpeg1videoparse/gstmp1videoparse.c: * gst/mpeg1videoparse/gstmp1videoparse.h: * gst/mpeg1videoparse/mp1videoparse.vcproj: * gst/mpegvideoparse/Makefile.am: * gst/mpegvideoparse/mpegpacketiser.c: (mpeg_packetiser_init), (mpeg_packetiser_free), (mpeg_packetiser_add_buf), (mpeg_packetiser_flush), (mpeg_find_start_code), (get_next_free_block), (complete_current_block), (append_to_current_block), (start_new_block), (handle_packet), (collect_packets), (mpeg_packetiser_handle_eos), (mpeg_packetiser_get_block), (mpeg_packetiser_next_block): * gst/mpegvideoparse/mpegpacketiser.h: * gst/mpegvideoparse/mpegvideoparse.c: (mpegvideoparse_get_type), (gst_mpegvideoparse_base_init), (gst_mpegvideoparse_class_init), (mpv_parse_reset), (gst_mpegvideoparse_init), (gst_mpegvideoparse_dispose), (set_par_from_dar), (set_fps_from_code), (mpegvideoparse_parse_seq), (gst_mpegvideoparse_time_code), (gst_mpegvideoparse_flush), (mpegvideoparse_drain_avail), (gst_mpegvideoparse_chain), (mpv_parse_sink_event), (gst_mpegvideoparse_change_state), (plugin_init): * gst/mpegvideoparse/mpegvideoparse.h: * gst/mpegvideoparse/mpegvideoparse.vcproj: Port mpeg1videoparse to 0.10 and give it rank SECONDARY-1, so that it's below existing decoders. Rename it to mpegvideoparse to reflect that it handles MPEG-1 and MPEG-2 now. Re-write the parsing code so that it collects packets differently and timestamps Picture packets correctly. Add a list of FIXME's at the top.
Diffstat (limited to 'gst/mpegvideoparse/Makefile.am')
-rw-r--r--gst/mpegvideoparse/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gst/mpegvideoparse/Makefile.am b/gst/mpegvideoparse/Makefile.am
new file mode 100644
index 00000000..4f935788
--- /dev/null
+++ b/gst/mpegvideoparse/Makefile.am
@@ -0,0 +1,9 @@
+
+plugin_LTLIBRARIES = libgstmpegvideoparse.la
+
+libgstmpegvideoparse_la_SOURCES = mpegvideoparse.c mpegpacketiser.c
+libgstmpegvideoparse_la_CFLAGS = $(GST_CFLAGS)
+libgstmpegvideoparse_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS)
+libgstmpegvideoparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = mpegvideoparse.h mpegpacketiser.h