summaryrefslogtreecommitdiffstats
path: root/gst/mve/Makefile.am
diff options
context:
space:
mode:
authorJens Granseuer <jensgr@gmx.net>2007-01-11 11:39:56 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-01-11 11:39:56 +0000
commit5dbec4ecf422943e0a9b7dadb16106b29e0753ca (patch)
treea874c5d91bc2227b7880dc5e5db337e7669c2b81 /gst/mve/Makefile.am
parentabe3e58b1b29867f0728cf0d108602833287e0cf (diff)
downloadgst-plugins-bad-5dbec4ecf422943e0a9b7dadb16106b29e0753ca.tar.gz
gst-plugins-bad-5dbec4ecf422943e0a9b7dadb16106b29e0753ca.tar.bz2
gst-plugins-bad-5dbec4ecf422943e0a9b7dadb16106b29e0753ca.zip
Add Interplay MVE format demuxer/decoder and muxer/encoder. Demuxer doesn't support seeking yet, but seems to work fi...
Original commit message from CVS: Patch by: Jens Granseuer <jensgr at gmx net> * configure.ac: * gst/mve/Makefile.am: * gst/mve/TODO: * gst/mve/gstmve.c: * gst/mve/gstmvedemux.c: * gst/mve/gstmvedemux.h: * gst/mve/gstmvemux.c: * gst/mve/gstmvemux.h: * gst/mve/mve.h: * gst/mve/mveaudiodec.c: * gst/mve/mveaudioenc.c: * gst/mve/mvevideodec16.c: * gst/mve/mvevideodec8.c: * gst/mve/mvevideoenc16.c: * gst/mve/mvevideoenc8.c: Add Interplay MVE format demuxer/decoder and muxer/encoder. Demuxer doesn't support seeking yet, but seems to work fine otherwise. Closes #348973.
Diffstat (limited to 'gst/mve/Makefile.am')
-rw-r--r--gst/mve/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/gst/mve/Makefile.am b/gst/mve/Makefile.am
new file mode 100644
index 00000000..3b1a5a4c
--- /dev/null
+++ b/gst/mve/Makefile.am
@@ -0,0 +1,20 @@
+plugin_LTLIBRARIES = libgstmve.la
+
+libgstmve_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstmve_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS)
+libgstmve_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+libgstmve_la_SOURCES = \
+ gstmve.c \
+ gstmvemux.c \
+ gstmvedemux.c \
+ mveaudiodec.c \
+ mvevideodec8.c \
+ mvevideodec16.c \
+ mveaudioenc.c \
+ mvevideoenc8.c \
+ mvevideoenc16.c
+
+noinst_HEADERS = gstmvedemux.h gstmvemux.h mve.h
+
+EXTRA_DIST = TODO