summaryrefslogtreecommitdiffstats
path: root/gst/nsf/Makefile.am
diff options
context:
space:
mode:
authorAndreas Henriksson <andreas@fatal.set>2008-03-25 15:56:13 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-03-25 15:56:13 +0000
commita4d0dacec222cbeb9853b56f4900f5881d67b99b (patch)
tree953651f2ca39872d58fc2d0212cd9b2919088850 /gst/nsf/Makefile.am
parent09ec92549f052d8cb8c157107ccd1359e6f2da1b (diff)
downloadgst-plugins-bad-a4d0dacec222cbeb9853b56f4900f5881d67b99b.tar.gz
gst-plugins-bad-a4d0dacec222cbeb9853b56f4900f5881d67b99b.tar.bz2
gst-plugins-bad-a4d0dacec222cbeb9853b56f4900f5881d67b99b.zip
gst/nsf/: Update our internal nosefart to nosefart-2.7-mls to fix segfaults on some files. Fixes bug #498237.
Original commit message from CVS: Patch by: Andreas Henriksson <andreas at fatal dot set> * gst/nsf/Makefile.am: * gst/nsf/dis6502.h: * gst/nsf/fds_snd.c: * gst/nsf/fds_snd.h: * gst/nsf/fmopl.c: * gst/nsf/fmopl.h: * gst/nsf/gstnsf.c: * gst/nsf/log.c: * gst/nsf/log.h: * gst/nsf/memguard.c: * gst/nsf/memguard.h: * gst/nsf/mmc5_snd.c: * gst/nsf/mmc5_snd.h: * gst/nsf/nes6502.c: * gst/nsf/nes6502.h: * gst/nsf/nes_apu.c: * gst/nsf/nes_apu.h: * gst/nsf/nsf.c: * gst/nsf/nsf.h: * gst/nsf/osd.h: * gst/nsf/types.h: * gst/nsf/vrc7_snd.c: * gst/nsf/vrc7_snd.h: * gst/nsf/vrcvisnd.c: * gst/nsf/vrcvisnd.h: Update our internal nosefart to nosefart-2.7-mls to fix segfaults on some files. Fixes bug #498237. Remove some // comments, fix some compiler warnings and use pow() instead of a slow, selfmade implementation.
Diffstat (limited to 'gst/nsf/Makefile.am')
-rw-r--r--gst/nsf/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/gst/nsf/Makefile.am b/gst/nsf/Makefile.am
index 75968254..152791e9 100644
--- a/gst/nsf/Makefile.am
+++ b/gst/nsf/Makefile.am
@@ -9,7 +9,8 @@ NOSEFART_SOURCES=fmopl.c \
fds_snd.c \
nes6502.c \
nsf.c \
- vrcvisnd.c
+ vrcvisnd.c \
+ memguard.c
NOSEFART_INCLUDES=fmopl.h \
log.h \
@@ -22,7 +23,8 @@ NOSEFART_INCLUDES=fmopl.h \
nes6502.h \
nsf.h \
types.h \
- vrcvisnd.h
+ vrcvisnd.h \
+ memguard.h
libgstnsf_la_SOURCES = gstnsf.c $(NOSEFART_SOURCES)