summaryrefslogtreecommitdiffstats
path: root/gst/real/Makefile.am
diff options
context:
space:
mode:
authorLutz Mueller <lutz@topfrose.de>2007-01-06 10:41:46 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-01-06 10:41:46 +0000
commitbda3b5839ae2c899afb4719a4dab4b62a7c7f8dd (patch)
tree047b67928497f8e01b03b91f0093366232007742 /gst/real/Makefile.am
parent1bf15564bf9ff6d5e1b70816e80aeae2d2c1e1a8 (diff)
downloadgst-plugins-bad-bda3b5839ae2c899afb4719a4dab4b62a7c7f8dd.tar.gz
gst-plugins-bad-bda3b5839ae2c899afb4719a4dab4b62a7c7f8dd.tar.bz2
gst-plugins-bad-bda3b5839ae2c899afb4719a4dab4b62a7c7f8dd.zip
gst/real/: Added RealAudio wrapper elementfactory.
Original commit message from CVS: Patch by: Lutz Mueller <lutz@topfrose.de> * gst/real/Makefile.am: * gst/real/gstreal.c: (plugin_init): * gst/real/gstrealaudiodec.c: (gst_real_audio_dec_chain), (gst_real_audio_dec_setcaps), (gst_real_audio_dec_init), (gst_real_audio_dec_base_init), (gst_real_audio_dec_change_state), (gst_real_audio_dec_finalize), (gst_real_audio_dec_set_property), (gst_real_audio_dec_get_property), (gst_real_audio_dec_class_init): * gst/real/gstrealaudiodec.h: Added RealAudio wrapper elementfactory. Modified structures so it can also work on x86_64 using the adequate .so .
Diffstat (limited to 'gst/real/Makefile.am')
-rw-r--r--gst/real/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/gst/real/Makefile.am b/gst/real/Makefile.am
index 8096c579..63696591 100644
--- a/gst/real/Makefile.am
+++ b/gst/real/Makefile.am
@@ -1,9 +1,14 @@
plugin_LTLIBRARIES = libgstreal.la
-libgstreal_la_SOURCES = gstrealvideodec.c gstreal.c
+libgstreal_la_SOURCES = \
+ gstrealvideodec.c \
+ gstrealaudiodec.c \
+ gstreal.c
libgstreal_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS)
libgstreal_la_LIBADD = $(GST_BASE_LIBS)
libgstreal_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstrealvideodec.h \ No newline at end of file
+noinst_HEADERS = \
+ gstrealvideodec.h \
+ gstrealaudiodec.h \ No newline at end of file