summaryrefslogtreecommitdiffstats
path: root/gst/selector/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2008-01-29 07:38:31 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2008-01-29 07:38:31 +0000
commit83e305cf5dd437f5dd30f2ef78de18a2e8dc3438 (patch)
treeb2f9b30db8853ba5f261f7168ad0e9448ffe0f1a /gst/selector/Makefile.am
parentc459b9da7d7fe346bceeb4968fae6959aa0f7697 (diff)
downloadgst-plugins-bad-83e305cf5dd437f5dd30f2ef78de18a2e8dc3438.tar.gz
gst-plugins-bad-83e305cf5dd437f5dd30f2ef78de18a2e8dc3438.tar.bz2
gst-plugins-bad-83e305cf5dd437f5dd30f2ef78de18a2e8dc3438.zip
Replace the switch plugin with the selector plugin. Add output- selector as the opposite of input-selectoo (was switc...
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-bad-plugins-docs.sgml: * docs/plugins/gst-plugins-bad-plugins-sections.txt: * docs/plugins/gst-plugins-bad-plugins.args: * docs/plugins/gst-plugins-bad-plugins.hierarchy: * docs/plugins/gst-plugins-bad-plugins.interfaces: * docs/plugins/gst-plugins-bad-plugins.signals: * docs/plugins/inspect/plugin-metadata.xml: * docs/plugins/inspect/plugin-selector.xml: * docs/plugins/inspect/plugin-soundtouch.xml: * docs/plugins/inspect/plugin-switch.xml: * gst/selector/.cvsignore: * gst/selector/Makefile.am: * gst/selector/gstinputselector.c: * gst/selector/gstinputselector.h: * gst/selector/gstoutputselector.c: * gst/selector/gstoutputselector.h: * gst/selector/gstselector-marshal.list: * gst/selector/gstselector.c: * gst/selector/selector.vcproj: * gst/switch/.cvsignore: * gst/switch/Makefile.am: * gst/switch/gstswitch-marshal.list: * gst/switch/gstswitch.c: * gst/switch/gstswitch.h: * gst/switch/switch.vcproj: * tests/icles/.cvsignore: * tests/icles/Makefile.am: * tests/icles/output-selector-test.c: Replace the switch plugin with the selector plugin. Add output- selector as the opposite of input-selectoo (was switch). Add a test for output-selector. Add docs for the elements. The vcproj needs update. Fixes #500142.
Diffstat (limited to 'gst/selector/Makefile.am')
-rw-r--r--gst/selector/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/gst/selector/Makefile.am b/gst/selector/Makefile.am
new file mode 100644
index 00000000..ddeb90fd
--- /dev/null
+++ b/gst/selector/Makefile.am
@@ -0,0 +1,22 @@
+glib_enum_prefix = gst_selector
+
+include $(top_srcdir)/common/glib-gen.mak
+
+built_sources = gstselector-marshal.c
+built_headers = gstselector-marshal.h
+
+BUILT_SOURCES = $(built_sources) $(built_headers)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = gstselector-marshal.list
+
+plugin_LTLIBRARIES = libgstselector.la
+
+libgstselector_la_SOURCES = gstselector.c gstinputselector.c gstoutputselector.c
+nodist_libgstselector_la_SOURCES = $(built_sources)
+libgstselector_la_CFLAGS = $(GST_CFLAGS)
+libgstselector_la_LIBADD =
+libgstselector_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS)
+
+noinst_HEADERS = gstinputselector.h gstoutputselector.h $(built_headers)