summaryrefslogtreecommitdiffstats
path: root/gst/spectrum/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2007-09-06 07:21:22 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2007-09-06 07:21:22 +0000
commit76a3fd7100246d47d3dcf08cd1e3370adca244af (patch)
tree8ed36919f4ad868314fa6cec4b4df4f34c999819 /gst/spectrum/Makefile.am
parent27f25ccd9bc38a0fb685bf26b28d3f5d5023b110 (diff)
downloadgst-plugins-bad-76a3fd7100246d47d3dcf08cd1e3370adca244af.tar.gz
gst-plugins-bad-76a3fd7100246d47d3dcf08cd1e3370adca244af.tar.bz2
gst-plugins-bad-76a3fd7100246d47d3dcf08cd1e3370adca244af.zip
Port GstSpectrum to GstAudioFilter and libgstfft, add support for int32, float and double, use floats for the message...
Original commit message from CVS: * configure.ac: * gst/spectrum/Makefile.am: * gst/spectrum/demo-audiotest.c: (draw_spectrum), (message_handler), (main): * gst/spectrum/demo-osssrc.c: (draw_spectrum), (message_handler): * gst/spectrum/gstspectrum.c: (gst_spectrum_base_init), (gst_spectrum_class_init), (gst_spectrum_init), (gst_spectrum_dispose), (gst_spectrum_set_property), (gst_spectrum_get_property), (gst_spectrum_start), (gst_spectrum_setup), (gst_spectrum_message_new), (gst_spectrum_transform_ip): * gst/spectrum/gstspectrum.h: Port GstSpectrum to GstAudioFilter and libgstfft, add support for int32, float and double, use floats for the message contents, average all FFTs done in one interval for better results, use a better windowing function, allow posting the phase in the message and actually do an FFT with the requested number of bands instead of interpolating. * tests/check/elements/spectrum.c: (GST_START_TEST), (spectrum_suite): Improve the units tests by checking for a 11025Hz sine wave and add unit tests for all 4 supported sample types.
Diffstat (limited to 'gst/spectrum/Makefile.am')
-rw-r--r--gst/spectrum/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/spectrum/Makefile.am b/gst/spectrum/Makefile.am
index db66dd6c..e161abbf 100644
--- a/gst/spectrum/Makefile.am
+++ b/gst/spectrum/Makefile.am
@@ -1,10 +1,10 @@
plugin_LTLIBRARIES = libgstspectrum.la
-libgstspectrum_la_SOURCES = gstspectrum.c fix_fft.c
+libgstspectrum_la_SOURCES = gstspectrum.c
libgstspectrum_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_CFLAGS)
-libgstspectrum_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(GST_LIBS)
+libgstspectrum_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(GST_LIBS) -lgstaudio-$(GST_MAJORMINOR) -lgstfft-$(GST_MAJORMINOR) $(LIBM)
libgstspectrum_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstspectrum.h