summaryrefslogtreecommitdiffstats
path: root/gst/speexresample/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-10-30 12:43:44 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-10-30 12:43:44 +0000
commit12766882b5d6ffcb8c48f2fa0a1f19ab17c05077 (patch)
tree83a8473ea4c6dea91928397eb5bb871100d1e2e6 /gst/speexresample/Makefile.am
parent51262eeb4c2741369bcdd5440d8be4f618e99af2 (diff)
downloadgst-plugins-bad-12766882b5d6ffcb8c48f2fa0a1f19ab17c05077.tar.gz
gst-plugins-bad-12766882b5d6ffcb8c48f2fa0a1f19ab17c05077.tar.bz2
gst-plugins-bad-12766882b5d6ffcb8c48f2fa0a1f19ab17c05077.zip
Add support for double samples as input and refactor the usage of the different compilation flavors of the speex resa...
Original commit message from CVS: * gst/speexresample/Makefile.am: * gst/speexresample/arch.h: * gst/speexresample/gstspeexresample.c: (gst_speex_resample_stop), (gst_speex_resample_get_unit_size), (gst_speex_resample_get_funcs), (gst_speex_resample_init_state), (gst_speex_resample_update_state), (gst_speex_resample_reset_state), (gst_speex_resample_parse_caps), (_gcd), (gst_speex_resample_transform_size), (gst_speex_resample_set_caps), (gst_speex_resample_push_drain), (gst_speex_resample_process), (gst_speex_resample_transform), (gst_speex_resample_query), (gst_speex_resample_set_property): * gst/speexresample/gstspeexresample.h: * gst/speexresample/resample.c: * gst/speexresample/speex_resampler.h: * gst/speexresample/speex_resampler_double.c: * gst/speexresample/speex_resampler_wrapper.h: * tests/check/elements/speexresample.c: (setup_speexresample), (test_perfect_stream_instance), (GST_START_TEST), (test_discont_stream_instance): Add support for double samples as input and refactor the usage of the different compilation flavors of the speex resampler.
Diffstat (limited to 'gst/speexresample/Makefile.am')
-rw-r--r--gst/speexresample/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gst/speexresample/Makefile.am b/gst/speexresample/Makefile.am
index 3e0c4924..f4d1534d 100644
--- a/gst/speexresample/Makefile.am
+++ b/gst/speexresample/Makefile.am
@@ -3,7 +3,8 @@ plugin_LTLIBRARIES = libgstspeexresample.la
libgstspeexresample_la_SOURCES = \
gstspeexresample.c \
speex_resampler_int.c \
- speex_resampler_float.c
+ speex_resampler_float.c \
+ speex_resampler_double.c
libgstspeexresample_la_CFLAGS = \
$(GST_PLUGINS_BASE_CFLAGS) \