summaryrefslogtreecommitdiffstats
path: root/gst/videocrop/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2006-09-02 15:30:45 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-09-02 15:30:45 +0000
commit7e69aee2235e401680ca441a449e6b741e8c5837 (patch)
tree7ca0a1674338ba407d0f12f46e15029b5eba511a /gst/videocrop/Makefile.am
parent4998a5a548e61816fb1a2838b7f72be3f1be9919 (diff)
downloadgst-plugins-bad-7e69aee2235e401680ca441a449e6b741e8c5837.tar.gz
gst-plugins-bad-7e69aee2235e401680ca441a449e6b741e8c5837.tar.bz2
gst-plugins-bad-7e69aee2235e401680ca441a449e6b741e8c5837.zip
Port/rewrite videocrop from scratch for GStreamer-0.10, and make it support all formats videoscale supports (#345653).
Original commit message from CVS: * configure.ac: * gst/videocrop/Makefile.am: * gst/videocrop/gstvideocrop.c: (gst_video_crop_base_init), (gst_video_crop_class_init), (gst_video_crop_init), (gst_video_crop_get_image_details_from_caps), (gst_video_crop_get_unit_size), (gst_video_crop_transform_packed), (gst_video_crop_transform_planar), (gst_video_crop_transform), (gst_video_crop_transform_dimension), (gst_video_crop_transform_dimension_value), (gst_video_crop_transform_caps), (gst_video_crop_set_caps), (gst_video_crop_set_property), (gst_video_crop_get_property), (plugin_init): Port/rewrite videocrop from scratch for GStreamer-0.10, and make it support all formats videoscale supports (#345653).
Diffstat (limited to 'gst/videocrop/Makefile.am')
-rw-r--r--gst/videocrop/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/gst/videocrop/Makefile.am b/gst/videocrop/Makefile.am
index 81c41990..6cf889aa 100644
--- a/gst/videocrop/Makefile.am
+++ b/gst/videocrop/Makefile.am
@@ -1,9 +1,12 @@
-
plugin_LTLIBRARIES = libgstvideocrop.la
+# Note: we only use defines from gst/video/video.h, but none
+# of the functions, so we don't need to link to libgstvideo
+
libgstvideocrop_la_SOURCES = gstvideocrop.c
-libgstvideocrop_la_CFLAGS = $(GST_CFLAGS)
-libgstvideocrop_la_LIBADD =
+libgstvideocrop_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(LIBOIL_CFLAGS)
+libgstvideocrop_la_LIBADD = $(GST_BASE_LIBS) $(LIBOIL_LIBS)
libgstvideocrop_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS =