summaryrefslogtreecommitdiffstats
path: root/pkgconfig/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-07-01 19:41:07 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-07-01 19:41:07 +0000
commit5e55d73a7c14877eae918fcea3f506cf49011152 (patch)
tree2a6de859f517515c26840aa459fc798d6efdf9f5 /pkgconfig/Makefile.am
parentc3c686f779d6bde9e493255a46462754da42d29c (diff)
downloadgst-plugins-bad-5e55d73a7c14877eae918fcea3f506cf49011152.tar.gz
gst-plugins-bad-5e55d73a7c14877eae918fcea3f506cf49011152.tar.bz2
gst-plugins-bad-5e55d73a7c14877eae918fcea3f506cf49011152.zip
remove old pc files
Original commit message from CVS: remove old pc files
Diffstat (limited to 'pkgconfig/Makefile.am')
-rw-r--r--pkgconfig/Makefile.am31
1 files changed, 4 insertions, 27 deletions
diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
index 49cd45fe..6b2cd965 100644
--- a/pkgconfig/Makefile.am
+++ b/pkgconfig/Makefile.am
@@ -1,28 +1,10 @@
-if USE_GCONF
-GCONF_PC=gstreamer-gconf-@GST_MAJORMINOR@.pc
-GCONF_PC_UNINSTALLED=gstreamer-gconf-@GST_MAJORMINOR@-uninstalled.pc
-else
-GCONF_PC=
-GCONF_PC_UNINSTALLED=
-endif
-
### all of the standard pc files we need to generate
pcverfiles = \
- $(GCONF_PC) \
- gstreamer-interfaces-@GST_MAJORMINOR@.pc \
- gstreamer-libs-@GST_MAJORMINOR@.pc \
- gstreamer-media-info-@GST_MAJORMINOR@.pc \
- gstreamer-play-@GST_MAJORMINOR@.pc \
- gstreamer-plugins-@GST_MAJORMINOR@.pc
+ gstreamer-libs-@GST_MAJORMINOR@.pc
+
pcverfiles_uninstalled = \
- $(GCONF_PC_UNINSTALLED) \
- gstreamer-interfaces-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-media-info-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc \
- gstreamer-plugins-@GST_MAJORMINOR@-uninstalled.pc
+ gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc
-pcverfiles_gconf = $(GCONF_PC) $(GCONF_PC_UNINSTALLED)
all-local: $(pcverfiles) $(pcverfiles_uninstalled)
### how to generate versioned .pc files from .pc files in this dir
@@ -36,12 +18,7 @@ pkgconfig_DATA = $(pcverfiles)
CLEANFILES = $(pcverfiles) $(pcverfiles_uninstalled)
pcinfiles = \
- gstreamer-gconf.pc.in gstreamer-gconf-uninstalled.pc.in \
- gstreamer-interfaces.pc.in gstreamer-interfaces-uninstalled.pc.in \
- gstreamer-libs.pc.in gstreamer-libs-uninstalled.pc.in \
- gstreamer-media-info.pc.in gstreamer-media-info-uninstalled.pc.in \
- gstreamer-play.pc.in gstreamer-play-uninstalled.pc.in \
- gstreamer-plugins.pc.in gstreamer-plugins-uninstalled.pc.in
+ gstreamer-libs.pc.in gstreamer-libs-uninstalled.pc.in
DISTCLEANFILES = $(pcinfiles:.in=)
EXTRA_DIST = $(pcinfiles)