summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2006-02-20 21:19:59 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2006-02-20 21:19:59 +0000
commit0c0067a1b01d44017cdffe1be559ee8af1e68f32 (patch)
tree6b72d6f5eece6169fa32abc5c2544d270a2e1316 /sys/Makefile.am
parent961d07acb1fc0fd475d58d76bc641e8e7986987d (diff)
downloadgst-plugins-bad-0c0067a1b01d44017cdffe1be559ee8af1e68f32.tar.gz
gst-plugins-bad-0c0067a1b01d44017cdffe1be559ee8af1e68f32.tar.bz2
gst-plugins-bad-0c0067a1b01d44017cdffe1be559ee8af1e68f32.zip
Port ximagesrc to 0.10 (Closes #304795)
Original commit message from CVS: * configure.ac: * sys/Makefile.am: * sys/ximagesrc/Makefile.am: * sys/ximagesrc/ximagesrc.c: (gst_ximagesrc_return_buf), (gst_ximagesrc_open_display), (gst_ximagesrc_start), (gst_ximagesrc_stop), (gst_ximagesrc_unlock), (gst_ximagesrc_recalc), (composite_pixel), (gst_ximagesrc_ximage_get), (gst_ximagesrc_create), (gst_ximagesrc_set_property), (gst_ximagesrc_get_property), (gst_ximagesrc_clear_bufpool), (gst_ximagesrc_base_init), (gst_ximagesrc_dispose), (gst_ximagesrc_finalize), (gst_ximagesrc_get_caps), (gst_ximagesrc_set_caps), (gst_ximagesrc_fixate), (gst_ximagesrc_class_init), (gst_ximagesrc_init), (plugin_init): * sys/ximagesrc/ximagesrc.h: * sys/ximagesrc/ximageutil.c: (ximageutil_handle_xerror), (ximageutil_check_xshm_calls), (ximageutil_xcontext_get), (ximageutil_xcontext_clear), (ximageutil_calculate_pixel_aspect_ratio), (gst_ximagesrc_buffer_finalize), (gst_ximage_buffer_free), (gst_ximagesrc_buffer_init), (gst_ximagesrc_buffer_class_init), (gst_ximagesrc_buffer_get_type), (gst_ximageutil_ximage_new), (gst_ximageutil_ximage_destroy): * sys/ximagesrc/ximageutil.h: Port ximagesrc to 0.10 (Closes #304795)
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index b64b99e8..ad8614a7 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -34,6 +34,12 @@ else
GL_DIR=
endif
-SUBDIRS = $(GL_DIR)
+if USE_X
+XIMAGESRC_DIR=ximagesrc
+else
+XIMAGESRC_DIR=
+endif
+
+SUBDIRS = $(GL_DIR) $(XIMAGESRC_DIR)
-DIST_SUBDIRS = glsink
+DIST_SUBDIRS = glsink ximagesrc