summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-20 20:25:24 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-20 20:25:24 +0000
commite382fe90cb1f3933f2334a1acb23b1d57cfaeeec (patch)
tree673cdd364691a09b69c852419dbdbeb8f938b02a /sys/Makefile.am
parent3eebb84a1fdbfbc10b41765d92516d2f06e5698f (diff)
downloadgst-plugins-bad-e382fe90cb1f3933f2334a1acb23b1d57cfaeeec.tar.gz
gst-plugins-bad-e382fe90cb1f3933f2334a1acb23b1d57cfaeeec.tar.bz2
gst-plugins-bad-e382fe90cb1f3933f2334a1acb23b1d57cfaeeec.zip
unforming dir names
Original commit message from CVS: unforming dir names
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 101ea5a5..98297dc5 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -1,5 +1,17 @@
-### use HAVE_ stuff to decide on dirs
-DIRS=qcam v4l vcdsrc vgasink xvideosink
+### FIXME use HAVE_ stuff to decide on dirs
+if USE_VGA
+VGA_SUBDS=vga
+else
+VGA_SUBDS=
+endif
-DIST_SUBDIRS=qcam v4l vcdsrc vgasink xvideosink
+if USE_OSS
+OSS_SUBDS=oss
+else
+OSS_SUBDS=
+endif
+
+SUBDIRS=$(OSS_SUBDS) qcam v4l vcd $(VGA_SUBDS) xvideo
+
+DIST_SUBDIRS=oss qcam v4l vcd vga xvideo