summaryrefslogtreecommitdiffstats
path: root/sys/Makefile.am
diff options
context:
space:
mode:
authorGernot Ziegler <gz@lysator.liu.se>2004-08-09 20:14:51 +0000
committerDavid Schleef <ds@schleef.org>2004-08-09 20:14:51 +0000
commitfa1b6c756ad85636d2400c34479a7a4ac8f47e8e (patch)
treec0a9174fc025e34f3ac87ce3530ca362db402dae /sys/Makefile.am
parentabc2e390832daa94ba20f717495581fb22a1916a (diff)
downloadgst-plugins-bad-fa1b6c756ad85636d2400c34479a7a4ac8f47e8e.tar.gz
gst-plugins-bad-fa1b6c756ad85636d2400c34479a7a4ac8f47e8e.tar.bz2
gst-plugins-bad-fa1b6c756ad85636d2400c34479a7a4ac8f47e8e.zip
GL sink plugin. (Bug #147302)
Original commit message from CVS: Patch from Gernot Ziegler <gz@lysator.liu.se> rewriting the GL sink plugin. (Bug #147302) * configure.ac: Test for OpenGL * sys/Makefile.am: Use test for OpenGL * sys/glsink/Makefile.am: * sys/glsink/glimagesink.c: rewrite * sys/glsink/glimagesink.h: rewrite
Diffstat (limited to 'sys/Makefile.am')
-rw-r--r--sys/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys/Makefile.am b/sys/Makefile.am
index 9f53cdb3..7028846a 100644
--- a/sys/Makefile.am
+++ b/sys/Makefile.am
@@ -70,9 +70,15 @@ else
CDROM_DIR=
endif
+if USE_OPENGL
+GL_DIR=glsink
+else
+GL_DIR=
+endif
+
SUBDIRS=$(DXR3_DIR) $(OSS_DIR) $(OSX_AUDIO_DIR) $(OSX_VIDEO_DIR) $(QCAM_DIR) \
$(SUNAUDIO_DIR) $(V4L_DIR) $(V4L2_DIR) $(VCD_DIR) $(CDROM_DIR) \
- $(XI_DIR) $(XV_DIR)
+ $(XI_DIR) $(XV_DIR) $(GL_DIR)
DIST_SUBDIRS=dxr3 oss osxaudio osxvideo qcam sunaudio v4l v4l2 vcd ximage \
xvimage glsink cdrom