summaryrefslogtreecommitdiffstats
path: root/sys/acmenc/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@xiph.org>2008-08-20 21:44:22 +0000
committerMichael Smith <msmith@xiph.org>2008-08-20 21:44:22 +0000
commit5c2b8e80444013268fb11c46e1961b39ca307c76 (patch)
tree9cfe01355e9c1564f3528a62b42942d15c82fbd8 /sys/acmenc/Makefile.am
parente2c08fe7360b03477ccbeef57dab648cfe2874aa (diff)
downloadgst-plugins-bad-5c2b8e80444013268fb11c46e1961b39ca307c76.tar.gz
gst-plugins-bad-5c2b8e80444013268fb11c46e1961b39ca307c76.tar.bz2
gst-plugins-bad-5c2b8e80444013268fb11c46e1961b39ca307c76.zip
Add new windows ACM encoder wrapper.
Original commit message from CVS: * configure.ac: * sys/Makefile.am: * sys/acmenc/Makefile.am: * sys/acmenc/acmenc.c: Add new windows ACM encoder wrapper.
Diffstat (limited to 'sys/acmenc/Makefile.am')
-rw-r--r--sys/acmenc/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys/acmenc/Makefile.am b/sys/acmenc/Makefile.am
new file mode 100644
index 00000000..a3971e49
--- /dev/null
+++ b/sys/acmenc/Makefile.am
@@ -0,0 +1,9 @@
+plugin_LTLIBRARIES = libgstacmencsink.la
+
+libgstacmencsink_la_SOURCES = acmenc.c
+libgstacmencsink_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstacmencsink_la_LIBADD = $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstriff-$(GST_MAJORMINOR) -lmsacm32
+libgstacmencsink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTSOUND_LDFLAGS)
+