summaryrefslogtreecommitdiffstats
path: root/sys/acmmp3dec/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@songbirdnest.com>2009-04-08 11:52:46 -0700
committerDave Robillard <dave@drobilla.net>2009-05-03 12:03:14 -0400
commit6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0 (patch)
tree440bba54195c83ae3dd0c89f6f58f31ab7fd0420 /sys/acmmp3dec/Makefile.am
parentb8de3969acdb19bcb68738d512c6ef29a1646a73 (diff)
downloadgst-plugins-bad-6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0.tar.gz
gst-plugins-bad-6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0.tar.bz2
gst-plugins-bad-6225d5a6bdf22ff968171d5c8b450a6afd7a8eb0.zip
acmenc, acmmp3dec, sdp: link to all requires libraries on win32.
Add winsock for windows (for sdp). Link to all the plugins-base libs we indirectly use for acmmenc and acmmp3dec.
Diffstat (limited to 'sys/acmmp3dec/Makefile.am')
-rw-r--r--sys/acmmp3dec/Makefile.am23
1 files changed, 14 insertions, 9 deletions
diff --git a/sys/acmmp3dec/Makefile.am b/sys/acmmp3dec/Makefile.am
index c1a28e75..27c895c5 100644
--- a/sys/acmmp3dec/Makefile.am
+++ b/sys/acmmp3dec/Makefile.am
@@ -1,9 +1,14 @@
-plugin_LTLIBRARIES = libgstacmmp3dec.la
-
-libgstacmmp3dec_la_SOURCES = acmmp3dec.c
-libgstacmmp3dec_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS) $(ACMMP3DEC_CFLAGS)
-libgstacmmp3dec_la_LIBADD = $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
- -lgstriff-$(GST_MAJORMINOR) -lmsacm32
-libgstacmmp3dec_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTSOUND_LDFLAGS)
-
+plugin_LTLIBRARIES = libgstacmmp3dec.la
+
+libgstacmmp3dec_la_SOURCES = acmmp3dec.c
+libgstacmmp3dec_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(ACMMP3DEC_CFLAGS)
+libgstacmmp3dec_la_LIBADD = \
+ $(GST_BASE_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstriff-$(GST_MAJORMINOR) \
+ -lgstaudio-$(GST_MAJORMINOR) \
+ -lgsttag-$(GST_MAJORMINOR) \
+ -lmsacm32
+libgstacmmp3dec_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTSOUND_LDFLAGS)
+