summaryrefslogtreecommitdiffstats
path: root/sys/osxvideo/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@oblong.net>2009-04-20 13:09:46 +0200
committerAndy Wingo <wingo@wingomac.bcn.oblong.net>2009-04-20 16:18:59 +0200
commit1bd852073d3440b810fb8a3f2d9f5e8b82febcc0 (patch)
tree66016d960e595fa8f42c5b58e67582782739b5fb /sys/osxvideo/Makefile.am
parent0ad5dec0190c77a9c2c511f9b75df773cbab23be (diff)
downloadgst-plugins-bad-1bd852073d3440b810fb8a3f2d9f5e8b82febcc0.tar.gz
gst-plugins-bad-1bd852073d3440b810fb8a3f2d9f5e8b82febcc0.tar.bz2
gst-plugins-bad-1bd852073d3440b810fb8a3f2d9f5e8b82febcc0.zip
add osxvideosrc
* configure.ac: * sys/Makefile.am: * sys/osxvideo/Makefile.am: Autoconfiscation. * sys/osxvideo/osxvideoplugin.m: * sys/osxvideo/osxvideosrc.h: * sys/osxvideo/osxvideosrc.c: Add osxvideosrc. Should fix #153684. Patch-by: Ole André Vadla Ravnås <ole.andre.ravnas@tandberg.com> Patch-by: Ali Sabil <ali.sabil@tandberg.com> Patch-by: Barracuda Networks <justin@affinix.com>
Diffstat (limited to 'sys/osxvideo/Makefile.am')
-rw-r--r--sys/osxvideo/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys/osxvideo/Makefile.am b/sys/osxvideo/Makefile.am
new file mode 100644
index 00000000..dd46e99c
--- /dev/null
+++ b/sys/osxvideo/Makefile.am
@@ -0,0 +1,18 @@
+
+plugin_LTLIBRARIES = libgstosxvideosrc.la
+
+libgstosxvideosrc_la_SOURCES = osxvideoplugin.m osxvideosrc.c
+libgstosxvideosrc_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) -Wno-deprecated-declarations
+libgstosxvideosrc_la_LIBADD = \
+ $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
+ -lgstinterfaces-$(GST_MAJORMINOR)
+
+libgstosxvideosrc_la_LIBTOOLFLAGS = --tag=disable-static
+
+libgstosxvideosrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) \
+ -Wl,-framework -Wl,Cocoa -Wl,-framework -Wl,QuickTime
+
+AM_OBJCFLAGS=$(CFLAGS) $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS)
+
+noinst_HEADERS = osxvideosrc.h