summaryrefslogtreecommitdiffstats
path: root/sys/vdpau/Makefile.am
diff options
context:
space:
mode:
authorDave Robillard <dave@drobilla.net>2009-06-22 17:04:00 -0400
committerDave Robillard <dave@drobilla.net>2009-06-22 17:04:00 -0400
commit218878de5ea48b5acdf36070a73a50fd71f41741 (patch)
tree12384ce50f1af7eb61c2c18a0d6141595797bc53 /sys/vdpau/Makefile.am
parent925e83ee60c5406b2e5f0f39b0da0f90370efc27 (diff)
parenta2a0322df9a7005a01aafb5efc32fcc1179d205c (diff)
downloadgst-plugins-bad-218878de5ea48b5acdf36070a73a50fd71f41741.tar.gz
gst-plugins-bad-218878de5ea48b5acdf36070a73a50fd71f41741.tar.bz2
gst-plugins-bad-218878de5ea48b5acdf36070a73a50fd71f41741.zip
Merge branch 'master' of git://anongit.freedesktop.org/gstreamer/gst-plugins-bad into fdo
Conflicts: ext/ladspa/Makefile.am ext/ladspa/gstladspa.h ext/lv2/Makefile.am ext/lv2/gstlv2.h
Diffstat (limited to 'sys/vdpau/Makefile.am')
-rw-r--r--sys/vdpau/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys/vdpau/Makefile.am b/sys/vdpau/Makefile.am
new file mode 100644
index 00000000..93a7513a
--- /dev/null
+++ b/sys/vdpau/Makefile.am
@@ -0,0 +1,27 @@
+plugin_LTLIBRARIES = libgstvdpau.la
+
+libgstvdpau_la_SOURCES = \
+ gstvdpdevice.c \
+ gstvdpmpegdec.c \
+ mpegutil.c \
+ gstvdpvideoyuv.c \
+ gstvdpvideobuffer.c \
+ gstvdp.c \
+ gstvdpyuvvideo.c
+
+libgstvdpau_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(X11_CFLAGS) $(VDPAU_CFLAGS)
+libgstvdpau_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) $(X11_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
+ $(VDPAU_LIBS)
+libgstvdpau_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstvdpau_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = \
+ gstvdpdevice.h \
+ gstvdpmpegdec.h \
+ mpegutil.h \
+ gstvdpvideoyuv.h \
+ gstvdpvideobuffer.h \
+ gstvdpyuvvideo.h
+
+