summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-05-14 14:19:47 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-05-14 14:19:47 +0000
commit426c88452b75ab75766b2d4f00014dc75a7cfcc8 (patch)
treedffa3c9d6cdb4ef12c0936df7815b353994aa90b /tests/check/Makefile.am
parent8ed88a34d0b29d46629fce23d6b8e9d4a4522d40 (diff)
downloadgst-plugins-bad-426c88452b75ab75766b2d4f00014dc75a7cfcc8.tar.gz
gst-plugins-bad-426c88452b75ab75766b2d4f00014dc75a7cfcc8.tar.bz2
gst-plugins-bad-426c88452b75ab75766b2d4f00014dc75a7cfcc8.zip
tests/check/Makefile.am: Add deinterleave unit test to VALGRIND_TO_FIX, since it causes weird invalid free errors in ...
Original commit message from CVS: * tests/check/Makefile.am: Add deinterleave unit test to VALGRIND_TO_FIX, since it causes weird invalid free errors in valgrind/libc after _exit for some reason. * tests/check/elements/deinterleave.c: (pads_created), (set_channel_positions), (src_handoff_float32_8ch), (float_buffer_check_probe), (pad_added_setup_data_check_float32_8ch_cb), (make_fake_src_8chans_float32), (GST_START_TEST), (deinterleave_suite): Add some more deinterleave unit test bits I had locally.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 2c986a20..ecf61001 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -59,6 +59,7 @@ endif
VALGRIND_TO_FIX = \
+ elements/deinterleave \
elements/mpeg2enc \
elements/mplex
@@ -88,6 +89,9 @@ TESTS = $(check_PROGRAMS)
AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS) $(GST_OPTION_CFLAGS)
LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
+elements_deinterleave_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(CFLAGS) $(AM_CFLAGS)
+elements_deinterleave_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(LDADD)
+
elements_timidity_CFLAGS = $(GST_BASE_CFLAGS) $(AM_CFLAGS)
elements_timidity_LDADD = $(GST_BASE_LIBS) $(LDADD)