summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2007-07-19 09:08:30 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2007-07-19 09:08:30 +0000
commit6cbacb8a1497c21208edd0507986c2e263d17bfc (patch)
tree2aa99a9f9f7d7600c587e1899953d4625277dc37 /tests/check/Makefile.am
parenta6058388c17adeace60b9e8b1daa2087f788e717 (diff)
downloadgst-plugins-bad-6cbacb8a1497c21208edd0507986c2e263d17bfc.tar.gz
gst-plugins-bad-6cbacb8a1497c21208edd0507986c2e263d17bfc.tar.bz2
gst-plugins-bad-6cbacb8a1497c21208edd0507986c2e263d17bfc.zip
tests/check/Makefile.am: tests/check/elements/timidity.c (GST_START_TEST, timidity_suite, main):
Original commit message from CVS: * tests/check/Makefile.am: * tests/check/elements/timidity.c (GST_START_TEST, timidity_suite, main): Add typefind test for midi.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 9856fda5..6801c05e 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -38,6 +38,13 @@ else
check_neon =
endif
+if USE_TIMIDITY
+check_timidity=elements/timidity
+else
+check_timidity=
+endif
+
+
VALGRIND_TO_FIX = \
elements/mpeg2enc
@@ -48,6 +55,7 @@ VALGRIND_TESTS_DISABLE = \
check_PROGRAMS = \
$(check_mpeg2enc) \
$(check_neon) \
+ $(check_timidity) \
elements/rganalysis \
elements/rglimiter \
elements/rgvolume \
@@ -59,3 +67,6 @@ TESTS = $(check_PROGRAMS)
AM_CFLAGS = $(GST_OBJ_CFLAGS) $(GST_CHECK_CFLAGS) $(CHECK_CFLAGS)
LDADD = $(GST_OBJ_LIBS) $(GST_CHECK_LIBS) $(CHECK_LIBS)
+elements_timidity_CFLAGS = $(GST_BASE_CFLAGS) $(AM_CFLAGS)
+elements_timidity_LDADD = $(GST_BASE_LIBS) $(LDADD)
+