summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2007-09-20 15:06:23 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2007-09-20 15:06:23 +0000
commitac256b5d1580ce1691d38192132b3ebbfa661e3c (patch)
tree998a7ac34735ee7727ddb322df14ccdd9c19f7f2 /tests/check/Makefile.am
parent7067d01d2a9e46a52f347cfa777e5a50f1d41494 (diff)
downloadgst-plugins-bad-ac256b5d1580ce1691d38192132b3ebbfa661e3c.tar.gz
gst-plugins-bad-ac256b5d1580ce1691d38192132b3ebbfa661e3c.tar.bz2
gst-plugins-bad-ac256b5d1580ce1691d38192132b3ebbfa661e3c.zip
Fix memory leaks. More to come.
Original commit message from CVS: * ext/alsaspdif/alsaspdifsink.c: * ext/timidity/gsttimidity.c: * ext/timidity/gstwildmidi.c: * gst/mpegvideoparse/mpegvideoparse.c: Fix memory leaks. More to come. * tests/check/Makefile.am: * tests/check/generic/states.c: Improved state change unit test.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 945d9e6f..80a94e61 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -1,6 +1,6 @@
include $(top_srcdir)/common/check.mak
-CHECK_REGISTRY = $(top_builddir)/tests/check/test-registry.xml
+CHECK_REGISTRY = $(top_builddir)/tests/check/test-registry.reg
GST_TOOLS_DIR = $(top_builddir)/tools
@@ -12,7 +12,8 @@ REGISTRY_ENVIRONMENT = \
TESTS_ENVIRONMENT = \
$(REGISTRY_ENVIRONMENT) \
GST_PLUGIN_SYSTEM_PATH= \
- GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/sys:$(top_builddir)/ext:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR)
+ GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/sys:$(top_builddir)/ext:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR) \
+ STATE_IGNORE_ELEMENTS="glimagesink"
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
@@ -20,7 +21,7 @@ plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
install-pluginLTLIBRARIES:
# the core dumps of some machines have PIDs appended
-CLEANFILES = core.* test-registry.xml
+CLEANFILES = core.* test-registry.*
SUPPRESSIONS = $(top_srcdir)/common/gst.supp $(srcdir)/gst-plugins-bad.supp