summaryrefslogtreecommitdiffstats
path: root/tests/examples/camerabin/Makefile.am
diff options
context:
space:
mode:
authorDave Robillard <dave@drobilla.net>2009-06-22 17:04:00 -0400
committerDave Robillard <dave@drobilla.net>2009-06-22 17:04:00 -0400
commit218878de5ea48b5acdf36070a73a50fd71f41741 (patch)
tree12384ce50f1af7eb61c2c18a0d6141595797bc53 /tests/examples/camerabin/Makefile.am
parent925e83ee60c5406b2e5f0f39b0da0f90370efc27 (diff)
parenta2a0322df9a7005a01aafb5efc32fcc1179d205c (diff)
downloadgst-plugins-bad-218878de5ea48b5acdf36070a73a50fd71f41741.tar.gz
gst-plugins-bad-218878de5ea48b5acdf36070a73a50fd71f41741.tar.bz2
gst-plugins-bad-218878de5ea48b5acdf36070a73a50fd71f41741.zip
Merge branch 'master' of git://anongit.freedesktop.org/gstreamer/gst-plugins-bad into fdo
Conflicts: ext/ladspa/Makefile.am ext/ladspa/gstladspa.h ext/lv2/Makefile.am ext/lv2/gstlv2.h
Diffstat (limited to 'tests/examples/camerabin/Makefile.am')
-rw-r--r--tests/examples/camerabin/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/examples/camerabin/Makefile.am b/tests/examples/camerabin/Makefile.am
new file mode 100644
index 00000000..df88cf14
--- /dev/null
+++ b/tests/examples/camerabin/Makefile.am
@@ -0,0 +1,39 @@
+GST_CAMERABIN_GLADE_FILES = gst-camera.glade
+
+if HAVE_GLADE
+if HAVE_GTK
+
+GST_CAMERABIN_GTK_EXAMPLES = gst-camera
+
+gst_camera_SOURCES = gst-camera.c
+gst_camera_CFLAGS = \
+ -I$(top_builddir)/gst-libs \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(GLADE_CFLAGS) \
+ -DGST_USE_UNSTABLE_API
+gst_camera_LDADD = \
+ $(top_builddir)/gst-libs/gst/interfaces/libgstphotography-@GST_MAJORMINOR@.la \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstinterfaces-@GST_MAJORMINOR@ \
+ $(GST_LIBS) \
+ $(GLADE_LIBS)
+
+gladedir = $(datadir)/gstreamer-@GST_MAJORMINOR@/camera-apps
+glade_DATA = $(GST_CAMERABIN_GLADE_FILES)
+
+INCLUDES = -DCAMERA_APPS_GLADEDIR=\""$(gladedir)"\"
+
+else
+GST_CAMERABIN_GTK_EXAMPLES =
+endif
+else
+GST_CAMERABIN_GTK_EXAMPLES =
+endif
+
+gst_camera_perf_SOURCES = gst-camera-perf.c
+gst_camera_perf_CFLAGS = $(GST_CFLAGS)
+gst_camera_perf_LDADD = $(GST_LIBS)
+
+bin_PROGRAMS = gst-camera-perf $(GST_CAMERABIN_GTK_EXAMPLES)
+
+EXTRA_DIST = $(GST_CAMERABIN_GLADE_FILES)
+