summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-05-22 16:33:25 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-05-22 16:33:25 +0000
commit464df32d53bd1a4ab570276d3af6da4da1b4321a (patch)
tree2d1217bc7730f2918b71efdd366b7a58851ee7ee /tests/icles/Makefile.am
parent80ef4ca4d7449550b2c5aa05d55d7c697a7c1fab (diff)
downloadgst-plugins-bad-464df32d53bd1a4ab570276d3af6da4da1b4321a.tar.gz
gst-plugins-bad-464df32d53bd1a4ab570276d3af6da4da1b4321a.tar.bz2
gst-plugins-bad-464df32d53bd1a4ab570276d3af6da4da1b4321a.zip
tests/icles/: Small oss4 test that probes for available devices and retrieves their caps and mixer tracks and all tha...
Original commit message from CVS: * tests/icles/.cvsignore: * tests/icles/Makefile.am: * tests/icles/test-oss4.c: (opt_show_mixer_messages), (WAIT_TIME), (show_mixer_messages), (probe_mixer_tracks), (probe_pad), (probe_details), (probe_element), (main): Small oss4 test that probes for available devices and retrieves their caps and mixer tracks and all that. Also allows testing of mixer change messages on the bus.
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index db5a16c1..f2755a3f 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -1,3 +1,9 @@
+if USE_OSS4
+OSS4_TESTS=test-oss4
+else
+OSS4_TESTS=
+endif
+
if USE_SOUNDTOUCH
GST_SOUNDTOUCH_TESTS = pitch-test
@@ -40,6 +46,10 @@ equalizer_test_CFLAGS = $(GST_CFLAGS)
equalizer_test_LDADD = $(GST_LIBS)
equalizer_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+test_oss4_SOURCES = test-oss4.c
+test_oss4_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
+test_oss4_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-0.10 $(GST_LIBS)
+test_oss4_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
output_selector_test_SOURCES = output-selector-test.c
output_selector_test_CFLAGS = $(GST_CFLAGS)
@@ -47,6 +57,6 @@ output_selector_test_LDADD = $(GST_LIBS)
output_selector_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_PROGRAMS = $(GST_SOUNDTOUCH_TESTS) $(GST_METADATA_TESTS) \
+noinst_PROGRAMS = $(GST_SOUNDTOUCH_TESTS) $(GST_METADATA_TESTS) $(OSS4_TESTS) \
equalizer-test output-selector-test