summaryrefslogtreecommitdiffstats
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2008-01-29 07:38:31 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2008-01-29 07:38:31 +0000
commit83e305cf5dd437f5dd30f2ef78de18a2e8dc3438 (patch)
treeb2f9b30db8853ba5f261f7168ad0e9448ffe0f1a /tests/icles/Makefile.am
parentc459b9da7d7fe346bceeb4968fae6959aa0f7697 (diff)
downloadgst-plugins-bad-83e305cf5dd437f5dd30f2ef78de18a2e8dc3438.tar.gz
gst-plugins-bad-83e305cf5dd437f5dd30f2ef78de18a2e8dc3438.tar.bz2
gst-plugins-bad-83e305cf5dd437f5dd30f2ef78de18a2e8dc3438.zip
Replace the switch plugin with the selector plugin. Add output- selector as the opposite of input-selectoo (was switc...
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-bad-plugins-docs.sgml: * docs/plugins/gst-plugins-bad-plugins-sections.txt: * docs/plugins/gst-plugins-bad-plugins.args: * docs/plugins/gst-plugins-bad-plugins.hierarchy: * docs/plugins/gst-plugins-bad-plugins.interfaces: * docs/plugins/gst-plugins-bad-plugins.signals: * docs/plugins/inspect/plugin-metadata.xml: * docs/plugins/inspect/plugin-selector.xml: * docs/plugins/inspect/plugin-soundtouch.xml: * docs/plugins/inspect/plugin-switch.xml: * gst/selector/.cvsignore: * gst/selector/Makefile.am: * gst/selector/gstinputselector.c: * gst/selector/gstinputselector.h: * gst/selector/gstoutputselector.c: * gst/selector/gstoutputselector.h: * gst/selector/gstselector-marshal.list: * gst/selector/gstselector.c: * gst/selector/selector.vcproj: * gst/switch/.cvsignore: * gst/switch/Makefile.am: * gst/switch/gstswitch-marshal.list: * gst/switch/gstswitch.c: * gst/switch/gstswitch.h: * gst/switch/switch.vcproj: * tests/icles/.cvsignore: * tests/icles/Makefile.am: * tests/icles/output-selector-test.c: Replace the switch plugin with the selector plugin. Add output- selector as the opposite of input-selectoo (was switch). Add a test for output-selector. Add docs for the elements. The vcproj needs update. Fixes #500142.
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index b3fba24c..79d20316 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -11,6 +11,7 @@ else
GST_SOUNDTOUCH_TESTS =
endif
+
if USE_METADATA
if HAVE_GLADE
if HAVE_GTK
@@ -39,4 +40,13 @@ equalizer_test_CFLAGS = $(GST_CFLAGS)
equalizer_test_LDADD = $(GST_LIBS)
equalizer_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_PROGRAMS = $(GST_SOUNDTOUCH_TESTS) $(GST_METADATA_TESTS) equalizer-test
+
+output_selector_test_SOURCES = output-selector-test.c
+output_selector_test_CFLAGS = $(GST_CFLAGS)
+output_selector_test_LDADD = $(GST_LIBS)
+output_selector_test_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+
+noinst_PROGRAMS = $(GST_SOUNDTOUCH_TESTS) $(GST_METADATA_TESTS) \
+ equalizer-test output-selector-test
+