summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 518585cb..eabda12f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -607,7 +607,10 @@ GST_CHECK_FEATURE(X, [X libraries and plugins],
[ximagesink], [
AC_PATH_XTRA
dnl now try to find the HEADER
+ save_cflags=$CFLAGS
+ CFLAGS="$CFLAGS $X_CFLAGS"
AC_CHECK_HEADER(X11/Xlib.h, HAVE_X="yes", HAVE_X="no")
+ CFLAGS="$save_cflags"
if test "x$HAVE_X" = "xno"
then