summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac59
1 files changed, 59 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 492bedd4..631d5cf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -399,6 +399,64 @@ GST_CHECK_FEATURE(DTS, [dts library], dtsdec, [
AC_SUBST(DTS_LIBS)
])
+dnl *** DIVX ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIVX, true)
+GST_CHECK_FEATURE(DIVX, [divx plugins], divx, [
+ HAVE_DIVX=yes
+ AC_CHECK_HEADER(encore2.h, ,
+ [ AC_MSG_WARN([Divx4linux encore headers not found]) &&
+ HAVE_DIVX=no ] )
+ if [ test x$HAVE_DIVX = xyes ]; then
+ AC_MSG_CHECKING([Checking for valid divx4linux encore version])
+ AC_TRY_COMPILE([
+#include <encore2.h>
+#if ENCORE_VERSION != 20021024
+#error Wrong version of divx encore libraries
+#endif
+ ], [
+return 0;
+ ], [ HAVE_DIVX=yes && AC_MSG_RESULT(yes)],
+ [ HAVE_DIVX=no && AC_MSG_RESULT(no) &&
+ AC_MSG_WARN([Wrong version of divx4linux installed]) ])
+ fi
+ if [ test x$HAVE_DIVX = xyes ]; then
+ AC_CHECK_HEADER(decore.h, ,
+ [ AC_MSG_WARN([Divx4linux decoder headers not found]) &&
+ HAVE_DIVX=no ] )
+ fi
+ if [ test x$HAVE_DIVX = xyes ]; then
+ AC_MSG_CHECKING([Checking for valid divx4linux decore version])
+ AC_TRY_COMPILE([
+#include <decore.h>
+#if DECORE_VERSION != 20021112
+#error Wrong version of divx decore libraries
+#endif
+ ], [
+return 0;
+ ], [ HAVE_DIVX=yes && AC_MSG_RESULT(yes)],
+ [ HAVE_DIVX=no && AC_MSG_RESULT(no) &&
+ AC_MSG_WARN([Wrong version of divx4linux installed]) ])
+ fi
+ LIBS="-lm"
+ if test x$HAVE_DIVX = xyes; then
+ AC_CHECK_LIB(divxencore, encore, ,
+ [ AC_MSG_WARN([Divx4linux encore libs not found]) &&
+ HAVE_DIVX=no ] )
+ fi
+ if test x$HAVE_DIVX = xyes; then
+ AC_CHECK_LIB(divxdecore, decore, ,
+ [ AC_MSG_WARN([Divx4linux decore libs not found]) &&
+ HAVE_DIVX=no ] )
+ fi
+ if test x$HAVE_DIVX = xyes; then
+ DIVXENC_LIBS="-ldivxencore -lm"
+ DIVXDEC_LIBS="-ldivxdecore -lm"
+ AC_SUBST(DIVXENC_LIBS)
+ AC_SUBST(DIVXDEC_LIBS)
+ fi
+])
+
+
dnl *** musepack ***
translit(dnm, m, l) AM_CONDITIONAL(USE_MUSEPACK, true)
GST_CHECK_FEATURE(MUSEPACK, [musepackdec], musepack, [
@@ -579,6 +637,7 @@ ext/ivorbis/Makefile
ext/gsm/Makefile
ext/libmms/Makefile
ext/dts/Makefile
+ext/divx/Makefile
ext/musepack/Makefile
ext/sdl/Makefile
ext/xvid/Makefile