summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a9b89f0f..294348d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -266,6 +266,7 @@ AG_GST_CHECK_PLUGIN(dvdspu)
AG_GST_CHECK_PLUGIN(festival)
AG_GST_CHECK_PLUGIN(freeze)
AG_GST_CHECK_PLUGIN(h264parse)
+AG_GST_CHECK_PLUGIN(hdvparse)
AG_GST_CHECK_PLUGIN(id3tag)
AG_GST_CHECK_PLUGIN(librfb)
AG_GST_CHECK_PLUGIN(liveadder)
@@ -286,6 +287,7 @@ AG_GST_CHECK_PLUGIN(rtpmux)
AG_GST_CHECK_PLUGIN(scaletempo)
AG_GST_CHECK_PLUGIN(sdp)
AG_GST_CHECK_PLUGIN(selector)
+AG_GST_CHECK_PLUGIN(shapewipe)
AG_GST_CHECK_PLUGIN(siren)
AG_GST_CHECK_PLUGIN(speed)
AG_GST_CHECK_PLUGIN(subenc)
@@ -1308,10 +1310,13 @@ AG_GST_CHECK_FEATURE(SOUNDTOUCH, [soundtouch plug-in], soundtouch, [
[HAVE_SOUNDTOUCH=yes
HAVE_SOUNDTOUCH_1_4=no
SOUNDTOUCH_LIBS="$SOUNDTOUCH_LIBS -lBPM"],
- [PKG_CHECK_MODULES(SOUNDTOUCH, libSoundTouch,
- HAVE_SOUNDTOUCH=yes
- SOUNDTOUCH_LIBS="$SOUNDTOUCH_LIBS -lBPM",
- HAVE_SOUNDTOUCH=no)])])
+ [PKG_CHECK_MODULES(SOUNDTOUCH, libSoundTouch >= 1.4,
+ [HAVE_SOUNDTOUCH=yes],
+ [PKG_CHECK_MODULES(SOUNDTOUCH, libSoundTouch,
+ [HAVE_SOUNDTOUCH=yes
+ HAVE_SOUNDTOUCH_1_4=no
+ SOUNDTOUCH_LIBS="$SOUNDTOUCH_LIBS -lBPM"],
+ HAVE_SOUNDTOUCH=no)])])])
AC_SUBST(SOUNDTOUCH_CFLAGS)
AC_SUBST(SOUNDTOUCH_LIBS)
if test "x$HAVE_CXX" != "xyes"; then
@@ -1585,6 +1590,7 @@ gst/dvdspu/Makefile
gst/festival/Makefile
gst/freeze/Makefile
gst/h264parse/Makefile
+gst/hdvparse/Makefile
gst/id3tag/Makefile
gst/librfb/Makefile
gst/mpegdemux/Makefile
@@ -1604,6 +1610,7 @@ gst/rtpmux/Makefile
gst/scaletempo/Makefile
gst/sdp/Makefile
gst/selector/Makefile
+gst/shapewipe/Makefile
gst/siren/Makefile
gst/speed/Makefile
gst/subenc/Makefile
@@ -1639,6 +1646,7 @@ sys/winscreencap/Makefile
tests/examples/Makefile
tests/examples/directfb/Makefile
tests/examples/mxf/Makefile
+tests/examples/shapewipe/Makefile
tests/examples/scaletempo/Makefile
tests/examples/switch/Makefile
ext/amrwb/Makefile