summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e0c71400..a5b42b8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -227,8 +227,8 @@ if test "x$HAVE_CXX" != "xyes"; then
fi
dnl real plugin only works on i386 and x86_64 for the time being.
-if test "x$HAVE_CPU_I386" != "xyes" || test "xHAVE_CPU_X86_64" != "xyes"; then
- AC_MSG_WARN([Not building real plugin, only works on 32bit x86 platforms])
+if test "x$HAVE_CPU_I386" != "xyes" && test "x$HAVE_CPU_X86_64" != "xyes"; then
+ AC_MSG_WARN([Not building real plugin, only works on 32bit and 64bit x86 platforms])
GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | sed 's/real//g'`
fi