summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 42bbe84b..b0ddf9cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -572,11 +572,13 @@ dnl *** DTS ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DTS, true)
AG_GST_CHECK_FEATURE(DTS, [dts library], dtsdec, [
HAVE_DTS="yes"
- AG_GST_CHECK_LIBHEADER(DTS, dca, dca_init, -lm, dts.h,
+ AG_GST_CHECK_LIBHEADER(DTS, dca, dca_init, -lm, dca.h,
DTS_LIBS="-ldca -lm", HAVE_DTS="no")
if test $HAVE_DTS = "no"; then
AG_GST_CHECK_LIBHEADER(DTS, dts_pic, dts_init, -lm, dts.h,
- DTS_LIBS="-ldts_pic -lm")
+ [ DTS_LIBS="-ldts_pic -lm"
+ AC_DEFINE(DTS_OLD, 1, [Define if an old libdts is used])
+ ])
fi
AC_SUBST(DTS_LIBS)
])