summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6cc8aac1..eac91a3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1056,10 +1056,23 @@ dnl *** x264 (MPEG-4 part 10/h.264/AVC encoder) ***
translit(dnm, m, l) AM_CONDITIONAL(USE_X264, true)
AG_GST_CHECK_FEATURE(X264, [x264 plug-in], x264, [
AG_GST_CHECK_LIBHEADER(X264, x264, x264_nal_encode, -lm, x264.h,
- X264_LIBS="$LDFLAGS -lx264 -lm"
- X264_CFLAGS="$CFLAGS"
- AC_SUBST(X264_LIBS)
- AC_SUBST(X264_CFLAGS))
+ AC_MSG_CHECKING([for uptodate x264 API version])
+ dnl _stdint not yet generated, so no compiling
+ AC_TRY_CPP([
+ #include <x264.h>
+ #if X264_BUILD < 55
+ #error "x264 build too old"
+ #endif
+ ], [
+ AC_MSG_RESULT(yes)
+ X264_LIBS="$LDFLAGS -lx264 -lm"
+ X264_CFLAGS="$CFLAGS"
+ AC_SUBST(X264_LIBS)
+ AC_SUBST(X264_CFLAGS)
+ ], [
+ AC_MSG_RESULT(no)
+ HAVE_X264=no
+ ]))
])
dnl *** XVID ***