summaryrefslogtreecommitdiffstats
path: root/ext/amrwb/amrwb-code/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/amrwb/amrwb-code/Makefile.am')
-rw-r--r--ext/amrwb/amrwb-code/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/ext/amrwb/amrwb-code/Makefile.am b/ext/amrwb/amrwb-code/Makefile.am
new file mode 100644
index 00000000..a11be20c
--- /dev/null
+++ b/ext/amrwb/amrwb-code/Makefile.am
@@ -0,0 +1,44 @@
+noinst_LTLIBRARIES = libamrwb.la
+
+libamrwb_la_SOURCES = \
+ enc_acelp.c \
+ enc_dtx.c \
+ enc_gain.c \
+ enc_if.c \
+ enc_lpc.c \
+ enc_main.c \
+ enc_rom.c \
+ enc_util.c \
+ if_rom.c \
+ dec_acelp.c \
+ dec_dtx.c \
+ dec_gain.c \
+ dec_if.c \
+ dec_lpc.c \
+ dec_main.c \
+ dec_rom.c \
+ dec_util.c
+
+libamrwb_la_CFLAGS = -I./amrwb-code/c-code
+libamrwb_la_LIBADD = $(GST_BASE_LIBS) $(AMRWB_LIBS)
+libamrwb_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ dec_acelp.h \
+ dec_dtx.h \
+ dec_gain.h \
+ dec.h \
+ dec_if.h \
+ dec_lpc.h \
+ dec_main.h \
+ dec_util.h \
+ enc_acelp.h \
+ enc_dtx.h \
+ enc_gain.h \
+ enc.h \
+ enc_if.h \
+ enc_lpc.h \
+ enc_main.h \
+ enc_util.h \
+ if_rom.h \
+ typedef.h