summaryrefslogtreecommitdiffstats
path: root/ext/gme/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gme/Makefile.am')
-rw-r--r--ext/gme/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/ext/gme/Makefile.am b/ext/gme/Makefile.am
new file mode 100644
index 00000000..f9a7b139
--- /dev/null
+++ b/ext/gme/Makefile.am
@@ -0,0 +1,10 @@
+plugin_LTLIBRARIES = libgstgme.la
+
+libgstgme_la_SOURCES = gstgme.c
+
+libgstgme_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GME_CFLAGS)
+libgstgme_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(GME_LIBS)
+libgstgme_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstgme_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstgme.h