summaryrefslogtreecommitdiffstats
path: root/ext/hermes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/hermes/Makefile.am')
-rw-r--r--ext/hermes/Makefile.am21
1 files changed, 5 insertions, 16 deletions
diff --git a/ext/hermes/Makefile.am b/ext/hermes/Makefile.am
index f08b401b..452c2f56 100644
--- a/ext/hermes/Makefile.am
+++ b/ext/hermes/Makefile.am
@@ -1,21 +1,10 @@
-plugin_LTLIBRARIES = libgstcolorspace.la
+plugin_LTLIBRARIES = libgsthermescolorspace.la
-if HAVE_CPU_I386
-ARCHSRCS = yuv2rgb_mmx16.s
-else
-ARCHSRCS =
-endif
-
-if USE_HERMES
PLUGIN_EXTRA_LIBS = $(HERMES_LIBS)
-else
-PLUGIN_EXTRA_LIBS =
-endif
-libgstcolorspace_la_SOURCES = gstcolorspace.c yuv2yuv.c yuv2rgb.c rgb2yuv.c $(ARCHSRCS)
-libgstcolorspace_la_CFLAGS = $(GST_CFLAGS)
-libgstcolorspace_la_LIBADD = $(PLUGIN_EXTRA_LIBS)
-libgstcolorspace_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgsthermescolorspace_la_SOURCES = gsthermescolorspace.c
+libgsthermescolorspace_la_CFLAGS = $(GST_CFLAGS)
+libgsthermescolorspace_la_LIBADD = $(PLUGIN_EXTRA_LIBS)
+libgsthermescolorspace_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = gstcolorspace.h yuv2rgb.h yuv2yuv.h