summaryrefslogtreecommitdiffstats
path: root/ext/kate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/kate/Makefile.am')
-rw-r--r--ext/kate/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/ext/kate/Makefile.am b/ext/kate/Makefile.am
new file mode 100644
index 00000000..f907da5f
--- /dev/null
+++ b/ext/kate/Makefile.am
@@ -0,0 +1,20 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstkate.la
+
+# sources used to compile this plug-in
+libgstkate_la_SOURCES = gstkate.c gstkatedec.c gstkateenc.c gstkateparse.c gstkatetag.c gstkateutil.c
+if USE_TIGER
+libgstkate_la_SOURCES += gstkatetiger.c
+endif
+
+# flags used to compile this plugin
+libgstkate_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(TIGER_CFLAGS) $(KATE_CFLAGS)
+libgstkate_la_LIBADD = $(GST_PLUGIN_BASE_LIBS) -lgsttag-$(GST_MAJORMINOR) $(GST_LIBS) $(TIGER_LIBS) $(KATE_LIBS)
+libgstkate_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstkate_la_LIBTOOLFLAGS = --tag=disable-static
+
+# headers we need but don't want installed
+noinst_HEADERS = gstkate.h gstkatedec.h gstkateenc.h gstkateparse.h gstkatetag.h gstkateutil.h gstkatetiger.h
+
+EXTRA_DIST=README