summaryrefslogtreecommitdiffstats
path: root/ext/modplug/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/modplug/Makefile.am')
-rw-r--r--ext/modplug/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/ext/modplug/Makefile.am b/ext/modplug/Makefile.am
new file mode 100644
index 00000000..e9525627
--- /dev/null
+++ b/ext/modplug/Makefile.am
@@ -0,0 +1,9 @@
+plugin_LTLIBRARIES = libgstmodplug.la
+
+libgstmodplug_la_SOURCES = gstmodplug.cc
+libgstmodplug_la_CXXFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CXXFLAGS) $(MODPLUG_CFLAGS)
+libgstmodplug_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lstdc++ $(LIBM) $(MODPLUG_LIBS)
+libgstmodplug_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstmodplug_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstmodplug.h