summaryrefslogtreecommitdiffstats
path: root/ext/neon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/neon/Makefile.am')
-rw-r--r--ext/neon/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/ext/neon/Makefile.am b/ext/neon/Makefile.am
index 1da120dd..b5ea9a77 100644
--- a/ext/neon/Makefile.am
+++ b/ext/neon/Makefile.am
@@ -1,15 +1,9 @@
-plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
+plugin_LTLIBRARIES = libgstneonhttpsrc.la
-plugin_LTLIBRARIES = libgstneonhttpsrc.la
+libgstneonhttpsrc_la_SOURCES = gstneonhttpsrc.c
-libgstneonhttpsrc_la_SOURCES = gstneonhttpsrc.c
-
-libgstneonhttpsrc_la_CFLAGS = $(GST_CFLAGS) \
- $(NEON_CFLAGS)
-
-libgstneonhttpsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-
-libgstneonhttpsrc_la_LIBADD = $(GST_BASE_LIBS) \
- $(NEON_LIBS)
+libgstneonhttpsrc_la_CFLAGS = $(GST_CFLAGS) $(NEON_CFLAGS)
+libgstneonhttpsrc_la_LIBADD = $(GST_BASE_LIBS) $(NEON_LIBS)
+libgstneonhttpsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstneonhttpsrc.h