summaryrefslogtreecommitdiffstats
path: root/gst/asfmux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/asfmux/Makefile.am')
-rw-r--r--gst/asfmux/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/gst/asfmux/Makefile.am b/gst/asfmux/Makefile.am
new file mode 100644
index 00000000..0246102b
--- /dev/null
+++ b/gst/asfmux/Makefile.am
@@ -0,0 +1,24 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libgstasfmux.la
+
+# sources used to compile this plug-in
+libgstasfmux_la_SOURCES = gstasfmux.c \
+ gstasfobjects.c \
+ gstasfparse.c \
+ gstrtpasfpay.c \
+ gstasf.c
+
+# flags used to compile this plugin
+# add other _CFLAGS and _LIBS as needed
+libgstasfmux_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstasfmux_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstrtp-@GST_MAJORMINOR@
+libgstasfmux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+#libgstasfmux_la_LIBTOOLFLAGS = --tag=disable-static
+
+# headers we need but don't want installed
+noinst_HEADERS = gstasfmux.h \
+ gstasfobjects.h \
+ gstasfparse.h \
+ gstrtpasfpay.h