summaryrefslogtreecommitdiffstats
path: root/gst/id3tag/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/id3tag/Makefile.am')
-rw-r--r--gst/id3tag/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/gst/id3tag/Makefile.am b/gst/id3tag/Makefile.am
new file mode 100644
index 00000000..9595be0f
--- /dev/null
+++ b/gst/id3tag/Makefile.am
@@ -0,0 +1,19 @@
+plugin_LTLIBRARIES = libgstid3tag.la
+
+libgstid3tag_la_SOURCES = \
+ gsttagmux.c \
+ id3tag.c \
+ gstid3tag.c
+
+libgstid3tag_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_CFLAGS)
+
+libgstid3tag_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgsttag-$(GST_MAJORMINOR) \
+ $(GST_LIBS)
+
+libgstid3tag_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstid3tag_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstid3tag.h id3tag.h gsttagmux.h