summaryrefslogtreecommitdiffstats
path: root/gst/mpegtsmux/tsmux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/mpegtsmux/tsmux/Makefile.am')
-rw-r--r--gst/mpegtsmux/tsmux/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/gst/mpegtsmux/tsmux/Makefile.am b/gst/mpegtsmux/tsmux/Makefile.am
new file mode 100644
index 00000000..e995cf7c
--- /dev/null
+++ b/gst/mpegtsmux/tsmux/Makefile.am
@@ -0,0 +1,8 @@
+noinst_LTLIBRARIES = libtsmux.la
+
+libtsmux_la_CFLAGS = $(GST_CFLAGS)
+libtsmux_la_LIBADD = $(GST_LIBS)
+libtsmux_la_LDFLAGS = -module -avoid-version
+libtsmux_la_SOURCES = tsmux.c tsmuxstream.c
+
+noinst_HEADERS = crc.h tsmuxcommon.h tsmux.h tsmuxstream.h