summaryrefslogtreecommitdiffstats
path: root/gst/mxf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/mxf/Makefile.am')
-rw-r--r--gst/mxf/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/gst/mxf/Makefile.am b/gst/mxf/Makefile.am
new file mode 100644
index 00000000..0113d9d1
--- /dev/null
+++ b/gst/mxf/Makefile.am
@@ -0,0 +1,20 @@
+plugin_LTLIBRARIES = libgstmxf.la
+
+libgstmxf_la_SOURCES = \
+ mxf.c \
+ mxfdemux.c \
+ mxfparse.c \
+ mxfaes-bwf.c \
+ mxfmpeg.c
+
+libgstmxf_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
+libgstmxf_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS)
+libgstmxf_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ mxfdemux.h \
+ mxfparse.h \
+ mxfaes-bwf.h \
+ mxfmpeg.h \
+ mxftypes.h
+