summaryrefslogtreecommitdiffstats
path: root/gst/playondemand/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/playondemand/Makefile.am')
-rw-r--r--gst/playondemand/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/gst/playondemand/Makefile.am b/gst/playondemand/Makefile.am
index fc2b93b9..4a96570a 100644
--- a/gst/playondemand/Makefile.am
+++ b/gst/playondemand/Makefile.am
@@ -7,4 +7,11 @@ libgstplayondemand_la_CFLAGS = $(GST_CFLAGS)
noinst_HEADERS = gstplayondemand.h filter.func
-# EXTRA_DIST = README
+if HAVE_GTK
+noinst_PROGRAMS = demo-mp3
+endif
+
+demo_mp3_SOURCES = demo-mp3.c
+demo_mp3_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS)
+demo_mp3_LDFLAGS = $(GST_LIBS) $(GTK_LIBS)
+