summaryrefslogtreecommitdiffstats
path: root/gst/qtdemux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/qtdemux/Makefile.am')
-rw-r--r--gst/qtdemux/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/gst/qtdemux/Makefile.am b/gst/qtdemux/Makefile.am
index 5d1792ec..2c4aa52a 100644
--- a/gst/qtdemux/Makefile.am
+++ b/gst/qtdemux/Makefile.am
@@ -1,14 +1,16 @@
plugin_LTLIBRARIES = libgstqtdemux.la
-libgstqtdemux_la_CFLAGS = ${GST_CFLAGS}
-libgstqtdemux_la_LIBADD = $(GST_BASE_LIBS) $(ZLIB_LIBS)
+libgstqtdemux_la_CFLAGS = ${GST_CFLAGS} $(GST_PLUGINS_BASE_CFLAGS)
+libgstqtdemux_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) $(ZLIB_LIBS) \
+ -lgstrtp-@GST_MAJORMINOR@
libgstqtdemux_la_LDFLAGS = ${GST_PLUGIN_LDFLAGS}
-libgstqtdemux_la_SOURCES = qtdemux.c qtdemux_types.c qtdemux_dump.c
+libgstqtdemux_la_SOURCES = quicktime.c gstrtpxqtdepay.c qtdemux.c qtdemux_types.c qtdemux_dump.c
noinst_HEADERS = \
qtdemux.h \
qtdemux_types.h \
qtdemux_dump.h \
qtdemux_fourcc.h \
- qtpalette.h
+ qtpalette.h \
+ gstrtpxqtdepay.h