summaryrefslogtreecommitdiffstats
path: root/gst/selector/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/selector/Makefile.am')
-rw-r--r--gst/selector/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/gst/selector/Makefile.am b/gst/selector/Makefile.am
new file mode 100644
index 00000000..ddeb90fd
--- /dev/null
+++ b/gst/selector/Makefile.am
@@ -0,0 +1,22 @@
+glib_enum_prefix = gst_selector
+
+include $(top_srcdir)/common/glib-gen.mak
+
+built_sources = gstselector-marshal.c
+built_headers = gstselector-marshal.h
+
+BUILT_SOURCES = $(built_sources) $(built_headers)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = gstselector-marshal.list
+
+plugin_LTLIBRARIES = libgstselector.la
+
+libgstselector_la_SOURCES = gstselector.c gstinputselector.c gstoutputselector.c
+nodist_libgstselector_la_SOURCES = $(built_sources)
+libgstselector_la_CFLAGS = $(GST_CFLAGS)
+libgstselector_la_LIBADD =
+libgstselector_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS)
+
+noinst_HEADERS = gstinputselector.h gstoutputselector.h $(built_headers)